비개발자를 위한 Python (PlaLab)

비개발자를 위한 Python (PlaLab)

비개발자를 위한 Python (PlaLab) 비개발자를 위한 Python (PlaLab)

Python 설치 및 준비하기 (OSX)

파이썬 설치 + 이클립스 설치 + pydev 설치

본 게시글은 2015년 5월 현재 최신버전인 OSX 10.10.4를 기준으로 작성했습니다.

Python 3 설치시작

은혜롭게도 OSX에는 파이썬 2.7이 설치되어 있습니다. 학습을 하기에는 충분할 수 있지만 인터넷 강의를 따라가고 최신 교제에 개발환경을 맞추기 위해서 최신버전인 Python 3를 설치하기로 합니다. 

HomeBrew 설치

맥용 패키지 관리자 중 하나인 homeBrew를 설치해야 합니다. 리눅스에서는 자주 사용하는 wget 명령어를 OSX에서는 사용을 할 수 없으며 SVN의 한글 깨짐 현상 등 다양한 문제에 대해서 해결 방법을 제공합니다. 

Python3 설치

Homebrew를 설치한 다음에는 아래와 같이 코드를 입력하면 간단하게 파이썬3를 설치할  수 있습니다. 

brew install python3

설치후에는 간단하게 콘솔에서 python3 를 쳐보면 아래와 같은 결과를 볼 수 있습니다.

자 이제 파이썬은 설치가 모두 완료됐습니다. 
다음으로는 개발 환경(IDE)를 설치하겠습니다. 

이클립스 설치

다양한 IDE와 가벼운 텍스트 에디터가 있지만 본 수업에서는 범용적으로 사용하는 IDE 인 이클립스 환경에서 Python의 개발 플러그인 Pydev를 설치하고 진행하도록 하겠습니다. 본 수업은 글이 작성되는 시점에 가장 최신버전인 Eclipe Luna 환경에서 작성됐습니다. 

이클립스 다운로드

이클립스 설치 및 관련해서는 생활코딩 이고잉님의 강의를 아래에 첨부합니다. 

Pydev 설치

다음으로는 help >> Eclipse market 을 선택학 PyDev를 검색하고 설치를 합니다. 
이후 Preference 에서 아래 그림과 같이 PyDev가 보이는지를 확인합니다.

만약 해당 메뉴가 보이지 않는다면 이유는 Python3가 java7 이상의 버전을 지원하기 때문입니다.
따라서 jdk를 최신버전으로 다운받고, 이클립스의 vm을 최신버전으로 연결하면 사용이 가능합니다. 

댓글

댓글 본문
작성자
비밀번호
  1. 최동희
    Python3가 java7 이상의 버전을 지원한다는 얘기는
    ... Python3가 작동하려면 버전 7 이상인 java가 필수라는 얘기처럼 보입니다.
    ... 그런데 java를 설치하지 않은 우분투 데스크탑에서 Python3은 정상적으로 잘 작동합니다.
    .
    java 버전 문제는 이클립스나 PyDev의 문제가 아닐까 하는 생각이 들어
    (개발자가 아니라 저도 잘 모르지만 궁금해서) 글 남겨봅니다.
버전 관리
Dusskapark
현재 버전
선택 버전
graphittie 자세히 보기