Atom Editor

Script

댓글

댓글 본문
작성자
비밀번호
  1. 이슬
    ATOM 에서 script package 검색하면
    not found 뜨는데....
    뭐가 문제일까요?
  2. 히스토
    감사합니다! ATOM 편집기를 포기하고 있었는데 덕분에 해결할 수 있었습니다. ^^
    대화보기
    • 새벽의뉴욕
      window에서 script로 python 실행 시 아래처럼 글씨 깨지는 분들은 PATH설정이 안되어 있어서입니다.

      'python'��(��) ���� �Ǵ� �ܺ� ����, ������ �� �ִ� ���α׷�, �Ǵ�
      ��ġ ������ �ƴմϴ�.
      [Finished in 0.048s]

      저도 안되서 찾아본거라 공유드립니다.

      제어판 -> 시스템 -> 고급 시스템 설정 -> 고급 탭 -> 환경 변수
      Path 선택하신 후 편집 후 맨 마지막에 python 설치 경로 추가 후 저장(저는 C:\Python27 이렇게 추가했습니다.)

      atom 종료후 재실행 하신 후 script 해보시면 잘 될꺼에요~
    • harowaroi
      수업 감사합니다. 특히 emmet !!
    • 문찬영
      2016년 10월 3일(월)
      드디어 수강완료!!

      하단 Script창의 폰트를 키우는 방법을 못 찾는 것 빼곤 다 마침..!!
      글씨가 너무 작어서 볼 수 없음. 그러나 별도창으로 뜨는 방법이 있어 다행입니다...
      감사합니다~!!
    • sadad104
      한글 입력이 안되서 검색해보니 맨 위에다가

      import sys
      import io

      sys.stdout = io.TextIOWrapper(sys.stdout.detach(), encoding = 'utf-8')
      sys.stderr = io.TextIOWrapper(sys.stderr.detach(), encoding = 'utf-8')

      를 추가하고 밑에 줄부터 작업을 진행하시면 한글 출력이 가능하다고 하네요
      저는 아톰에서 해보니 잘 됬습니다.
    • 아르히
      패키지 설치하려고 했더니 이렇게 뜨네요
      파이썬이고 뭐고 아무것도 없어서 환경변수로 뭐 할라고 해도 할 것도 없어서 해결을 못하고 있습니다 ㅠ
      ����: ������ ���Ͽ� �ش��Ǵ� ������ ã�� ���߽��ϴ�.

      ������ ������ ã�� �� �����ϴ�.

      fs.js:794
      return binding.mkdir(pathModule._makeLong(path),
      ^

      Error: ENOENT: no such file or directory, mkdir 'C:\Program Files\Java\jdk1.8.0_77\bin;C:\Users\JSLHRD\AppData\Local\Temp\d-116820-1172-13dp807'
      at Error (native)
      at Object.fs.mkdirSync (fs.js:794:18)
      at Object.mkdirSync (C:\Users\JSLHRD\AppData\Local\atom\app-1.10.2\resources\app\apm\node_modules\temp\lib\temp.js:137:6)
      at Request.<anonymous> (C:\Users\JSLHRD\AppData\Local\atom\app-1.10.2\resources\app\apm\lib\install.js:332:41)
      at emitOne (events.js:77:13)
      at Request.emit (events.js:169:7)
      at Request.onRequestResponse (C:\Users\JSLHRD\AppData\Local\atom\app-1.10.2\resources\app\apm\node_modules\request\request.js:954:10)
      at emitOne (events.js:77:13)
      at ClientRequest.emit (events.js:169:7)
      at HTTPParser.parserOnIncomingClient [as onIncoming] (_http_client.js:430:21)
    • 김준석
      단축키 누르니까 cannot find module 'underscore' 라고 빨간색으로 뜨네요 ㅠㅠ 이거 해결할 방법 있을까요?
      제발 도와주세요 ㅠㅠ
    • 정원준
      제가 지금 이 상황인데요. 환경변수 처리를 어떻게 하셨나요? 알려주실수 있을까요?
      대화보기
      • sth6323
        파이썬이나 루비패치를설정에넣으라는게무슨말인가요..??? 아무리 봐도모르겠네요..ㅠ
        대화보기
        • sth6323
          'ruby'��(��) ���� �Ǵ� �ܺ� ����, ������ �� �ִ� ���α׷�, �Ǵ�
          ��ġ ������ �ƴմϴ�.
          [Finished in 0.048s]

          'python'��(��) ���� �Ǵ� �ܺ� ����, ������ �� �ִ� ���α׷�, �Ǵ�
          ��ġ ������ �ƴմϴ�.
          [Finished in 0.048s]

          아..계속 오류뜨네요 ㅠㅠ 진짜 도와주세요 ㅠㅠ
          환경변수그거는 해봤는데 뭐 아무반응없네요 ㅠㅠ


          -------------------------\d
          아 제가 환경변수 잘못한거였네요 환경변수로 해결했습니다. 여러분 ㅠㅠ
        • ibmike
          github를 선행 설치해야 영상에서 설명하는 script가 설치된다는군요
          설치하려고 하시는 분들은 참고하시길...

          그리고 어느분이 올리신 유용한 아톰 에디터 플러그인 정리해둔 사이트입니다.

          http://blog.jeonghwan.net......AC/

          이중에서 linter는 거의 필수겠네요
          linter를 언어별로 따로 설치하지 마시고 통합 linter를 설치하시는게 좋을거 같네요
          이름이 그냥 'linter'로 되어있습니다. 다운로드수 가장 많은...
        • 느와르
          ATOM에서 아예 안깔리면서 빨간색 안내문 뜨는 경우 : GitHub 설치 (로그인 불필요)
          기쁜마음으로 사용하려고 Shift+Ctrl+B했는데 이상하게 나오는 경우
          1. 빨간색으로 나오는경우 : 환경변수에서 사용할 언어 Python이나 Ruby Path 설정에 넣어주기
          막 무슨 꺠진 글씨로 나오는 경우
          2. ATOM 맨 아래 오른쪽에 내가적은 언어랑 맞는 건지 확인 (Ruby 같은경우 Ruby on Rails로 되있어서 깨짐)
        • 에단호크
          스크립트를 실행하면 모든 글씨가 깨져서 나오는데 이건 어떻게 된걸까요?
          맨오른쪽 하단의 설정은 UTF-8 / Python 으로 되어있습니다.
          혹시 한글이 아님에도 실행시 글씨가 깨져서 나오는 현상 겪으시는분...?
        • ㄹㅇㄹㅇ
          님말씀대로 에러메세지에서 GitHub다운받으라서 다운받았는데
          그후에
          apm -v로 몇버전인지 확인을 하고 다운을 받으라고 하는데요
          이건 어떻게 처리하나요?
          대화보기
          • nightwhale
            Script 플러그인을 설치하려고 하니 아래와 같은 메시지와 함께 설치가 되지 않네요 ㅜㅜ
            ATOM 상에서와 Command line 둘다 시도해봤는데도 계속 발생합니다.
            GitHub Desktop 설치해도 마찬가지고..
            맥OS X 엘캐피탄 사용 중입니다. 혹시 해결책이 있을까요..?

            npm WARN addRemoteGit git://github.com/monsterkodi/node-simple-plist.git resetting remote /Users/AJ/.atom/.apm/_git-remotes/git-github-com-monsterkodi-node-simple-plist-git-6a71a541 because of error: xcrun: error: invalid active developer path (/Library/Developer/CommandLineTools), missing xcrun at: /Library/Developer/CommandLineTools/usr/bin/xcrun
            npm ERR! git clone --template=/Users/AJ/.atom/.apm/_git-remotes/_templates --mirror git://github.com/monsterkodi/node-simple-plist.git /Users/AJ/.atom/.apm/_git-remotes/git-github-com-monsterkodi-node-simple-plist-git-6a71a541: xcrun: error: invalid active developer path (/Library/Developer/CommandLineTools), missing xcrun at: /Library/Developer/CommandLineTools/usr/bin/xcrun
            npm ERR! Darwin 15.6.0
            npm ERR! argv "/Applications/Atom.app/Contents/Resources/app/apm/bin/node" "/Applications/Atom.app/Contents/Resources/app/apm/node_modules/npm/bin/npm-cli.js" "--globalconfig" "/Users/AJ/.atom/.apm/.apmrc" "--userconfig" "/Users/AJ/.atom/.apmrc" "install" "/private/var/folders/09/qlcfn_kn47qdx674tmx5kmmc0000gn/T/d-116525-12230-1g48uu6/package.tgz" "--target=0.36.8" "--arch=x64"
            npm ERR! node v0.10.40
            npm ERR! npm v2.13.3
            npm ERR! code 1

            npm ERR! Command failed: xcrun: error: invalid active developer path (/Library/Developer/CommandLineTools), missing xcrun at: /Library/Developer/CommandLineTools/usr/bin/xcrun
            npm ERR!
            npm ERR!
            npm ERR! If you need help, you may report this error at:
            npm ERR! <https://github.com/npm/npm/issues>

            npm ERR! Please include the following file with any support request:
            npm ERR! /private/var/folders/09/qlcfn_kn47qdx674tmx5kmmc0000gn/T/apm-install-dir-116525-12230-vshe90/npm-debug.log
          • 김연규
            리눅스에서 failed to install script because Git was not found가 뜨실경우

            sudo apt install git

            터미널에서 입력하시면 됩니다.
          • fireclub
            failed to install script because Git was not found.
            https://windows.github.com에서 Github 설치하면되네요
          • 까미
            저도이렇게떠서 현재 사용못하고잇습니다ㅠ
            대화보기
            • 라조
              같은 문제 환경변수 추가로 해결했습니다.
              대화보기
              • Olramde
                핫키를 누르니 File Based runner not available for C. 라는 오류가 뜨는데 어떻게 해결해야할까요..
              • 보보
                github 오픈소스계에서 주류를 이루는 강력한 형상관리 툴이에요.
                jquery도 github에서 형상관리하고 있구요.
                node.js도 그렇구요~ 배워두면 프로젝트 관리하기 편해요^^;
              • 'python'��(��) ���� �Ǵ� �ܺ� ����, ������ �� �ִ� ���α׷�, �Ǵ�
                ��ġ ������ �ƴմϴ�.
                [Finished in 0.06s]

                이렇게 뜨는 이유가 뭔지 아시는분!
              • 소프트마니아
                저는 설치하고 로긴해보려고 가입까지 했습니다만 아마 설치만하면 될거같은데요.. 가입하셔도 별 상관엄서요 삼류 찌끄레기 사이트도 아니고 거 머시냐 소스공유하거나 팀 프로젝트 버전관리 같은거 하는걸껄요. 구글서 모르는거나 코드 검색해볼때 주로 저기께 보여질거에요 앞으로 코딩 쭈욱 하신다면 자주 사용하게될지도 모를곳이니 가입해두고 써보시는것도 좋겠죵.. 잘 모르는 사람이 주저리주저리...
                대화보기
                • GitHub 다운로드 했더니 무슨 로그인 하라고 하는데 가입해야하나요??
                  대화보기
                  • 소프트마니아
                    Installing “script@3.5.2” failed...
                    제 경우.. 거기 에러메시지에 나온 주소 https://windows.github.com 에 가서 GitHub 데스크탑 설치하니까 되데욤
                    대화보기
                    • script 인스톨이 안되네요 ㅠㅠ 인스톨 하고 나면
                      Installing “script@3.5.2” failed.Hide output…
                      Failed to install script because Git was not found.

                      The script package has module dependencies that cannot be installed without Git.

                      You need to install Git and add it to your path environment variable in order to install this package.

                      You can install Git by downloading, installing, and launching GitHub for Windows: https://windows.github.com

                      Run apm -v after installing Git to see what version has been detected.

                      이렇게 나오네요
                    • Marvin
                      저도 비슷한 오류가 생겨서 찾다가 보다가 나름의 해결책을 찾았어요. cmd 창에서 atom . 을 실행 시킨다음에 한 번 해보세요. 저 같은 경우는 아이콘으로 atom 실행해서 하면 안되고 cmd 창에서 atom . 을 실행시키니깐 script가 정상적으로 되는 것 같네요.
                      대화보기
                      • 윤정희
                        'python'��(��) ���� �Ǵ� �ܺ� ����, ������ �� �ִ� ���α׷�, �Ǵ�
                        ��ġ ������ �ƴմϴ�.
                        [Finished in 0.077s]

                        이 오류와 동일한 오류가 발생했는데, 말씀하신 제어판 설정을 변경해도 동일하게 증상이 나타나고 있습니다..
                        ㅜㅜ
                        대화보기
                        • Atom 업그레이드 이후에 script 업그레이드 하시고 재시작해보세요.
                          대화보기
                          • Python - 1.py:1
                            Unable to run
                            python
                            Did you start Atom from the command line?

                            atom .
                            Is it in your PATH?

                            PATH: C:\Python;C:\Users\Kim\AppData\Local\atom\bin

                            갑자기 이렇게 되면서 스크립트 실행이 안되는데 환경변수에서 path도 설치 디렉토리 맞게 설치해놨는데 왜 이럴까요....
                          • JS AHN
                            감사합니다!
                          • YongHwa Kwon
                            Thank you~!! ^^
                          • 기존 Path값은 그래로 두고, 설치된 Python 디렉토리를 추가하면 됩니다.

                            예 C:\Program Files\Python
                            대화보기
                            • 가뭄에 단비같은 답변 감사합니다. ㅠㅠ

                              기존에 변수 경로가아닌 새로운 이름으로 python 변수값 설정하려고 하는데

                              변수값은 파이썬 내용이있는 폴더가 와야하나요?
                              `
                              디렉토리 최종값은 어떤폴더가 되어야하는지... 알려주시면 감사하겠습니다. ~!
                            • 환경변수 설정하면 됩니다.

                              제어판->시스템->고급시스템설정->환경변수->Path선택->편집->새로만들기

                              Python, Rubi 디렉토리 입력
                              대화보기
                              • 광대승천
                                혹시 해결하셨나요 ?
                                저는 루비에서 같은 문제가 생겨서 해결못하고있습니다
                                대화보기
                                • 매일코딩
                                  잘들었습니다 재미있네요
                                • dankim
                                  Unable to run

                                  python
                                  Did you start Atom from the command line?

                                  atom .
                                  아톰안에서 실행하려 하니 이런 메세지가 뜹니다. 스크립트를 다운받아도 이러는데 해결방법있을까요?
                                • 감사합니다. ㅠ 근대 깔고 cmd에서는 돌아가는대 아톰에서만 안돌아가는거면 무슨문제가 있는건가요??
                                  대화보기
                                  • gwangyi
                                    python 설치가 안돼 있는거같아요. 파이선부터 깔고 패스 설정하셔야할듯
                                    대화보기
                                    • 안녕하세요 간단한 print (10)를 열려고 했는데

                                      'python'��(��) ���� �Ǵ� �ܺ� ����, ������ �� �ִ� ���α׷�, �Ǵ�
                                      ��ġ ������ �ƴմϴ�.
                                      [Finished in 0.077s]
                                      이렇게 나오네요 ㅠ 혹시 무엇이 문제인지 아시는분??
                                    • googler
                                      자바 수업때 했던 파일을 열려고했더니

                                      javac: file not found: Helloworld.java
                                      Usage: javac <options> <source files>
                                      use -help for a list of possible options

                                      라고 뜨는데 왜그런가요?
                                    • Han-Na Kim
                                      감사합니다. python&ruby 수업 감사히 잘 듣고 있으며, atom 설명도 잘 듣고 갑니다. 남은 수업도 끝까지 잘듣고 atom도 잘 활용할께요~^^
                                    • 통조림
                                      감사합니다
                                    • 검사무운
                                      잘 봤습니다.
                                      수업중에는 Script 패키지는 안 쓰시던데...
                                      아주 좋은 기능이네요.
                                    • 아하나
                                      from tkinter import *
                                      import random
                                      import time
                                      ...
                                      ...
                                      이렇게 시작되는 코드를 실행하면

                                      ImportError: No module named tkinter 라고 에러가 나옵니다.
                                      터미널에서 실행하면 문제없이 실행되는 코드이구요.
                                      이것을 어떻게 해야 해결을 할 수 있을까요?

                                      OS X에서 python 3.5, Atom 사용합니다.
                                    • 이경호
                                      ATOM 디자인도 깔끔하고 이식성도 뛰어나고 편리한 기능이 많네요. 툴 다루는데 익숙해지면 정말 효율적으로 작업할 수 있을 것 같네요. 잘보고갑니다~
                                    • tmflo
                                      맥 OS 최신버전에는 파이썬2.7이 설치되어있습니다.
                                      하지만, 파이썬3 이상을 쓰시려면 따로 다운받으셔야 합니다.
                                      대화보기
                                      • 고구려
                                        Python 컴파일러 설치 한적이 없는데... 맥에서 강좌에서 나온 내용 똑같이 코딩하고 cmd+i 했더니.... 동작하네요?
                                        왜 그럴까요?
                                      버전 관리
                                      egoing
                                      현재 버전
                                      선택 버전
                                      graphittie 자세히 보기