Database2 - Lowdb

설치 - Node.js

수업소개

Node.js 환경에서 lowdb를 설치하는 방법을 소개합니다. 
 

 

 

강의

 

 

 

소스코드

main.js

const low = require('lowdb')
const FileSync = require('lowdb/adapters/FileSync')
const adapter = new FileSync('db.json')
const db = low(adapter)

 

댓글

댓글 본문
작성자
비밀번호
  1. 상구미
    Global 옵션은 저도 유명한 프레임워크들만 사용해요 express, react 등등..
    대화보기
    • 삼고잉
      일단 설치 완료
    • Hyung Jun Choi
      npm을 이용해서 설치해도 mudules폴더가 안생기네요..ㅠ
      ---------------------------------------------------------------------------------
      추가.
      npm을 이용해 모듈을 설치할 때, -s 옵션을 줘서 node_modules폴더가 생기도록 하시는 것이 좋습니다.
      저는 괜히 -g 옵션을 줘서 글로벌로 설치하려고 했는데, 글로벌 설치에 관한 오류가 많아서 이리저리 삽질하느라 고생만 했네요.
      결국 웬만하면 글로벌 설치는 포기하고 로컬설치를 하는 것이 좋습니다.
    • Robert Eric
      editor는 vs code 쓰고 계신 것 같네요.ㅎㅎ 저도 vs code 씁니다
      대화보기
      • 그린이
        혹시 무슨 에디터를 이용하신건가요??

        그리고 sublime text3를 에디터로, 일반 cmd창을 터미널로 이용해서 사용할 수 있나요?
      • hallo88
        굉장히 흥미로운 주제네요. 관계형 데이터베이스만 사용하다가 좋은 내용 알아 갑니다.
      graphittie 자세히 보기