예제로 배우는 PyQt

예제 중심으로 배우는 PyQt 프로그래밍

예제로 배우는 PyQt 예제 중심으로 배우는 PyQt 프로그래밍

PyQT 설치

PyQt5 설치

기존의 내용은 오래된 내용으로 현재 설치방법과는 맞지 않아 혼란을 줄 수 있으므로 삭제하였습니다.

댓글을 참조하시어 설치하시기 바랍니다. 설치방법은 다시 정리하여 작성하겠습니다.

댓글

댓글 본문
작성자
비밀번호
  1. 임덕규
    설치를 시도하신 버전은 CPython 3.7 64비트 윈도우용입니다. 사용하고 계시는 플랫폼을 확인해보세요.
    대화보기
    • 김정인
      PyQt5수동으로 설치할 시
      pyqt5-sip를 설치해야되는어 모든 버전이
      PyQt5_sip-4.19.12-cp37-none-win_amd64.whl is not a supported wheel on this platform.
      위와같은 오류로 설치가 안되는데 혹시 설치방법을 알려주실수 있나요?
    • 임덕규
      장준혁님 말씀에 따르면 3.6.x버전대에서는 8월 기준으로 pyqt5-tools 설치가 된다고 하시네요.
      대화보기
      • 임덕규
        감사합니다.
        대화보기
        • 장준혁
          2018년 8월기준 파이썬 3.7에는 qt5-tools 지원이 안 됩니다. 3.6.x 설치하면 사용가능합니다.
        • 김예슬
          pyqt 상업용을 샀는데 설치하는 방법을 모르겠어서요 혹시 pyqt5 상업용을 설치하는 방법은 알 수 있을까요?
        • 이은환
          파이참 화면에서 CTRL+ALT+S 누르고 설정창으로 들어갑니다
          project : [subject]를 클릭하고 interpreter 설정을 클릭합니다

          오른쪽상단 +마크를 클릭합니다
          pyqt5를 검색하고 설치합니다
          나와서 새로고칩합니다
          대화보기
          • 임덕규
            현재 PyQt5-tools의 버전이 낮아서 그런거 같습니다. 제작자가 업데이트 해주기 전까지 필요한 툴들은 Qt5 의 최신 버전등을 설치해서 사용하실 수 있습니다.
            대화보기
            • Quan Lee
              mac에서 pip3 install pyqt5로 pyqt5는 설치되었으나,
              pip3 install pyqt5-tools로 하면 아래 에러가 뜹니다.

              Could not find a version that satisfies the requirement PyQt5-tools (from versions: )
              No matching distribution found for PyQt5-tools

              맥에서 설치했던 분 계시는지요?

              #최신 버전 아나콘다는 이미 설치되었습니다.
            • 안대철
              감사합니다! 많은 삽질을 했지만.. 결국 아래의 방식대로 하니까 되네요 ㅎㅎ
            • 소경현
              감사합니다!
              덕분에 삽질을 줄일 수 있었네요
              대화보기
              • 임덕규
                from PyQt5 import * 은 네임스페이스에 너무나 많은 항목을 나열하게 되어 좋지 못합니다.
                제가 작성해둔 예제에서 처럼 사용하는 모듈만 가져오시면 해당 문제도 해결될 뿐더러 앱구성이 한 눈에 들어와서 관리하기가 편해집니다. 참고하시기 바랍니다.
                대화보기
                • 임덕규
                  파이참 설정, Project Interpreter 항목에서 인터프리터를 지정해주세요. 사실 아이디 처럼 초보셔서 이 글도 힘드실 수도 있지만 인내심을 가지고 해당 항목을 찾아보시기 바랍니다.

                  사용하고 있는 파이참의 위치가 설정되어 있지 않기 때문에 발생하는 문제입니다.
                  대화보기
                  • 파이초보
                    준화님께서 말씀해주신대로 파이썬 설치 -> 파이썬 아나콘다 -> 파이참 설치했는데

                    파이참에서 from PyQt5 import *

                    여기에 에러가나고 모듈을찾을수가없다고 하는데 어떻게 해야하는지...
                  • 임덕규
                    네 고생 많으셨네요.
                    최근에는 설치가 많이 쉬워져서 pip가 설치가 된다면 윈도우즈와 리눅스 그리고 맥오에스에서는 쉽게 설치하실 수 있습니다.

                    pyqt5-tools 를 설치하셔야 디자이너와 pyrcc등을 사용하실 수 있습니다.
                    대화보기
                    • 준화
                      4시간 삽질했네요,,, 제 삽질 과정 기준으로 설명해드리겠습니다.
                      1. 먼저 아나콘다가 설치되어 있지 않다면 아나콘다를 설치합니다.
                      2. 아나콘다 콘솔 창에서 python -m pip install --upgrade pip으로 pip을 업그레이드 해줍니다.
                      3. pip install pyqt5로 pyqt5를 설치해줍니다.
                      4. pip install pyqt5-tools로 designer를 설치해줍니다.
                      5. C:\ProgramData\Anaconda3\Lib\site-packages\pyqt5-tools 에 designer 파일이 있습니다.

                      계속 안되다가 uninstall을 해보자 마음먹고 했더니 관리자권한 콘솔이 아니라 C 드라이브에 접근 제한이 뜨더군요. 그 과정에서 노출된 경로로 가봤더니 발견할 수 있었습니다.
                    • 임덕규
                      PyQt와 비슷한 사용법을 가진 PySide를 사용하시면 됩니다. PyQt는 GPL을 사용하고 있으며 라이센스 비용을 내면 GPL을 사용하지 않으셔도 됩니다. (최근에 그렇게 봤는데 정확한 내용은 리버뱅크 qna참조 바랍니다)
                      대화보기
                      • Python 초급자
                        Riverbank site에 가보니, PyQt에 License가 있는것 같은데, License를 피하는 방법도 있는지요?
                      • 지나가던
                        http://yudreyhepburn.tistory.com/23 이거대로 설치다하고 구문 대소문자 정확히 하니 되네요
                      • Sunjong Park
                        ubuntu 16.04 계열 설치방법입니다.
                        $ sudo apt install python3-pyqt5
                        $ sudo apt install pyqt5-dev-tools
                        $ sudo apt install qttools5-dev-tools

                        # 디자이너 실행
                        $ qtchooser -run-tool=designer -qt=5
                        혹은 아래 파일을 다음과 같이 수정
                        /usr/lib/x86_64-linux-gnu/qt-default/qtchooser/default.conf

                        /usr/lib/x86_64-linux-gnu/qt5/bin
                        /usr/lib/x86_64-linux-gnu
                      • 감사합니다. 댓글보고 잘 설치 했습니다!
                        대화보기
                        • 윈도우에 anaconda & eric6 설치 하고 싶습니다. 중간에 pypt5도 설치해야 하는데 아무리 설치해도 되지 않네요
                          도움 주실분 있을까요?
                          dplus25@naver.com 부탁드려요.
                        • FishermanTurtle
                          저 같은 경우 윈도우 10인데, Riverbank 홈페이지의 소스 패키지를 다운 받아서
                          어떻게 해보려고 삽질을 하는 등 계속 해메다가 최종적으로 여기 있는 댓글의 도움을
                          받아 설치했습니다. 혹시 보고 도움이 되실 분도 계실 것 같아 제가 했던 과정을 남깁니다.

                          준비 : 최신 버전의 파이썬을 설치한다.

                          (1) 윈도우 커맨드 창을 켠다

                          (2) 'cd C:\Users\사용자명\AppData\Local\Programs\Python\Python36\Scripts'를 입력한다.

                          (3) 'pip install PyQt5' 입력

                          (4) 'pip install PyQt5-tools' 입력

                          (5) C:\Users\사용자명\AppData\Local\Programs\Python\Python36\Lib\site-packages\pyqt5-tools 경로에 설치 완료.
                        • 김태성
                          맥북에 파이썬 3.6을 쓰고 있는데 pyqt5설치방법을 알려주세요
                          kimts0121@daum.net 으로 답변주세요
                        • Window 10, Anaconda 3 기준 설명

                          Anaconda 사용자라면 anaconda prompt에서 아래의 2개 명령을 실행한다.
                          pip install pyqt5
                          pip install pyqt5-tools

                          C:\Users\사용자명\Anaconda3\Lib\site-packages\pyqt5-tools 폴더 아래에 designer.exe 파일이 있음.
                        • ruydoo0711
                          다른 api때문에 python 3.3을 사용해야하는데

                          python 3.3에 맞는 pyqt 설치 방법을 도통 찾아봐도 모르겠습니다. ㅜㅜ
                        • 감사
                          휘밤님 했는데 잘 됩니다. 감사합니다.
                          대화보기
                          • Karoid
                            python 3.6 기준 pip 설치하려고
                            python -m pip install pyqt5
                            python -m pip install pyqt5-tools
                            명령하니까 제대로 작동하네요
                          • 휘밤님덕
                            아나콘다 쓰신다면

                            C:\Users\이름\Anaconda2\envs\py35\Lib\site-packages\pyqt5-tools

                            이런 경로에 있네요
                          • 휘밤
                            3시간 고생했네여

                            파이썬 3.5 이상 버전에서 명령창에서
                            pip install pyqt5 설치해주고
                            pip install pyqt5-tools 설치해주고

                            C:\Users\%USERNAME%\AppData\Local\Programs\Python\Python35-32\Lib\site-packages
                            경로에 들어가면 desinger.exe 파일이 있다.
                            파이썬 3.5미만에서는 안됩니다.
                          • batman
                            맥에서 설치하고 있는데요. python3.4.2입니다.
                            pip install pyqt5하는데, 자꾸 아래와 같은 메세지가 뜨네요.

                            No distributions at all found for sip>=4.19.1 (from pyqt5)

                            물론 SIP 버전은 4.19.2가 설치 되어 있습니다.
                          • 누굴까
                            https://sourceforge.net......qt/

                            여기 pyqt5 설치파일이 있습니다.

                            왜 이러는 걸까요
                          • onaccess1@gmail.com
                            저도 qt designer 설치하는데 어려움이 있었는데요.... python 3.5 에서 pyqt를 설치하려면 cmd 에서
                            >pip isntall pyqt5 라고 하시면 설치됩니다.
                            여기에 qt designer를 설치하시려면
                            >pip install pyqt5-tools
                            라고 치시면 pyqt-tools가 설치되는데... (전 아나콘다를 사용합니다.)
                            아나콘다 lib에 sitepackages안에 pyqt-tools에 들어가시면 designer가 들어가 있습니다.
                            전 이거 바로가기로 만들어서 사용하고 있네요...ㅜㅜ 저도 완전 설치파일을 찾지 못해서 완전 헤맸네요..ㅜㅜ
                          • onaccess1@gmail.com
                            요즘엔 installer 대신에 command line에서 명령어를 쳐서 설치하는군요....
                          • 유좌준
                            사이트에 들어가보니 파이썬 3.4에 qt5.5.0이 있는데 이걸 사용해도 강연에 차질이 없나요?
                            혹시 또 파이썬 3.5을 사용하여 프로그램을 진행중인데 사용해도 호환이 가능한가요?
                          • 궁금
                            Python 2.7.4 + Qt5.3.2 도 있나요?
                            링크 들어가보니, 목록에
                            py 3.4 + Qt4.8.6
                            py 3.4 + Qt5.3.2
                            py 2.7 + Qt4.8.6'
                            밖에 안보여서요...ㅠ.ㅠ
                          • 똘이
                            네, 설치는 위와 같이 진행하시면 됩니다.
                            대화보기
                            • 반민석
                              설치 어떻게 하는건지 좀 알려주시면 안되나요?
                            버전 관리
                            임덕규
                            현재 버전
                            선택 버전
                            graphittie 자세히 보기